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How to Diagnose Secure Messaging Not Loading on Contact Side

This article outlines issues you might be experiencing while using Comm100 Secure Messaging. You can see these error messages printed in your browser’s Developer Tools > Console.


Problem

  • When I try using the Comm100 Secure Messenger to chat with my visitors, I receive a Feature is not available message.
    feature is not available.png
  • When I try using the Comm100 Secure Messenger to chat with my visitors, I receive a Request is invalid message.
    request is invalid.png
  • When I try using the Comm100 Secure Messenger to chat with my visitors, I receive a Channel is disabled message.
    channel is disabled.png
  • When I try using the Comm100 Secure Messenger to chat with my visitors, I receive an Invalid token provided message.
    invalid token provided.png
  • When I try using the Comm100 Secure Messenger to chat with my visitors, I receive a Contact Service is temporarily unavailable message.
  • When I try using the Comm100 Secure Messenger to chat with my visitors, I receive an Access token service is temporarily unavailable message.


Cause

Here are the potential causes of these issues:

  • Feature is not available: Secure Messaging feature is not available for your site. 
  • Request is invalid: The siteid and messengerid in the installation code are not associated correctly.
  • Channel is disabled: The Secure Messenger is not enabled from the Comm100 Control Panel.
  • Invalid token provided: Either the token is sent incorrectly or the JWT validation method is not set up correctly.
  • Contact Service is temporarily unavailable: There could be an error while creating a contact or contact identity.
  • Access token service is temporarily unavailable: There could be an error while getting a messenger access token.


Solution

Here is the potential solution to these issues:

  • Feature is not available: Contact the Comm100 Support team.
  • Request is invalid: Check your installation code and ensure that the siteid and messengerid are provided correctly.
    siteid_messengerid.png
  • Channel is disabled: Enable the Secure Messaging channel from the Comm100 Control Panel. To learn how to enable Secure Messaging, see this article.
  • Invalid token provided: Ensure that the JWT payload is set up correctly. To set up the JWT payload, see this article.  Also, ensure that the JWT is validated correctly. To learn about JWT validation, see this article.  
  • Contact Service is temporarily unavailable: The error may resolve automatically. However, if the error persists, contact the Comm100 Support team.
  • Access token service is temporarily unavailable: Either it should resolve automatically or contact the Comm100 Support team. 

If you need help in troubleshooting your Secure Messenger, you can Chat with us.