This article details the possible causes of chat button display issues and suggests possible solutions to fix the issue.
Problem
- All my website visitors cannot see the chat button on my website.
- A portion of website visitors cannot see the chat button on my website.
Cause
The following could be the possible cause:
- There is an issue with how your Live Chat JavaScript Installation has been pasted into your website code.
- The visitor reporting this error has been banned.
- Chat Button is set to be visible only on certain Domain/URL in Live Chat > Campaign > Chat Button > Advanced.
- There are no agents online and the Hide Offline Button option is enabled.
- The chat button is hidden by some rules implemented on your website.
Solution
- Make sure your live chat code is pasted in-full to the webpage. You can find the correct installation code from the Control Panel Live Chat > Campaign > Installation.
- Check your Ban List under Live Chat > Settings > Ban. If the visitor reporting the issue has their IP address listed there, they will be unable to see the chat button. You can lift the ban by deleting their IP from the ban list. If their IP is not there, ask the visitor to clear their browser cookies.
- Clear the Display chat button on specified domains/URLs only check box from Live Chat > Campaign > Chat Button > Advanced.
- If you want there to be a live chat button on your website even when your agents are offline, keep the Hide chat button when my team is offline check box cleared from Live Chat > Campaign > Chat Button > Advanced.
- Ensure that there are no rules on your website that are overriding the visibility of the Chat Button.
If you need further assistance, contact us via live chat by clicking the chat button.