This article helps you solve the problem that you cannot receive WhatsApp messages.
Problem
After integrating my WhatsApp account with Comm100, I am unable to receive messages.
Cause
There are two possible reasons for the issue you are experiencing:
- Your Twilio number is not enabled for WhatsApp.
- The Webhook URL you are using is not correct.
Solution
- Log in to your Twilio account.
- Check in Twilio > Messaging > Senders > WhatsApp senders that your account has been approved.
- If your account is already approved, check the Webhook URL for incoming messages.
- Modify the Webhook URL as “https://messagingproxy.comm100.io/messagingproxy/mmm61yylzxl5va6i/whatsapp/whatsapp:{phonenumber}”.
You need to use your account number in place of {phonenumber}. For example, for Comm100, our Webhook URL is https://messagingproxy.comm100.io/messagingproxy/mmm61yylzxl5va6i/whatsapp/whatsapp:16475593520. - Click Save.
To know about the messaging proxy URL, you can chat with us.